Rekisteröidy    Kirjaudu sisään    Etusivu    FAQ

Etusivu » Imperiumi » Palaute




Aloita uusi ketju Vastaa viestiin  [ 8 viestiä ] 
 
Kirjoittaja Viesti
 Viestin otsikko: url -tagit ei toimi aina
 Viesti Lähetetty: 26 Touko 2010, 16:41 

Liittynyt: 03 Syys 2002, 16:00
Viestit: 2260
Paikkakunta: tre
Url tagit eivät näytä aina toimivan, varsinkaan jos quoten otsikkoon laittaa ne. Nyt pari päivää ollut kyseinen vika. Selaimena joko uusin FF tai Opera.

 
 Profiili  
 
 Viestin otsikko: Re: url -tagit ei toimi aina
 Viesti Lähetetty: 26 Touko 2010, 21:50 
Imperiumi Assistant

Liittynyt: 24 Elo 2002, 19:48
Viestit: 573
Paikkakunta: Kallio, Helsinki
cfe kirjoitti:
Url tagit eivät näytä aina toimivan, varsinkaan jos quoten otsikkoon laittaa ne. Nyt pari päivää ollut kyseinen vika. Selaimena joko uusin FF tai Opera.
Annatko esimerkin?

Todnäk. johtuu siitä, että URLissa on jotain siihen kuulumattomia merkkejä, jotka saavat phpbb:n ymmälleen. Esim. hakasulkeet luonnollisesti ovat tällaisia: [url=http://example/[a]?42=true]linkki[/url] ei toimi mutta sama erikoismerkit url-enkoodattuna toimii á la linkki.

Edit: Ja muistat kai oikean järjestyksen, url quoten lainausmerkkien sisään:
Koodi:
[quote="[url=http://lauta.imperiumi.net/viewtopic.php?p=766602#p766602]cfe[/url]"]
Url tagit eivät näytä aina toimivan, varsinkaan jos quoten otsikkoon laittaa ne. Nyt pari päivää ollut kyseinen vika. Selaimena joko uusin FF tai Opera.
[/quote]

 
 Profiili  
 
 Viestin otsikko: Re: url -tagit ei toimi aina
 Viesti Lähetetty: 27 Touko 2010, 13:52 

Liittynyt: 03 Syys 2002, 16:00
Viestit: 2260
Paikkakunta: tre
Scandal kirjoitti:
cfe kirjoitti:
Url tagit eivät näytä aina toimivan, varsinkaan jos quoten otsikkoon laittaa ne. Nyt pari päivää ollut kyseinen vika. Selaimena joko uusin FF tai Opera.
Annatko esimerkin?

Todnäk. johtuu siitä, että URLissa on jotain siihen kuulumattomia merkkejä, jotka saavat phpbb:n ymmälleen. Esim. hakasulkeet luonnollisesti ovat tällaisia: [url=http://example/[a]?42=true]linkki[/url] ei toimi mutta sama erikoismerkit url-enkoodattuna toimii á la linkki.

Edit: Ja muistat kai oikean järjestyksen, url quoten lainausmerkkien sisään:
Koodi:
[quote="[url=http://lauta.imperiumi.net/viewtopic.php?p=766602#p766602]cfe[/url]"]
Url tagit eivät näytä aina toimivan, varsinkaan jos quoten otsikkoon laittaa ne. Nyt pari päivää ollut kyseinen vika. Selaimena joko uusin FF tai Opera.
[/quote]


Esimerkkinä:

[url=http://www.hs.fi/politiikka/artikkeli/Sdp+lupaa+nuorille+töitä+hallituspaikan+vastineeksi/1135257133146]Hesari[/url] kirjoitti:
Sdp lupaa nuorille töitä hallituspaikan vastineeksi

bla bla blaa pla pla

 
 Profiili  
 
 Viestin otsikko: Re: url -tagit ei toimi aina
 Viesti Lähetetty: 27 Touko 2010, 14:25 

Liittynyt: 27 Tammi 2008, 16:09
Viestit: 992
Paikkakunta: Joensuu (/Kajaani)
cfe kirjoitti:
Esimerkkinä:

[url=http://www.hs.fi/politiikka/artikkeli/Sdp+lupaa+nuorille+töitä+hallituspaikan+vastineeksi/1135257133146]Hesari[/url] kirjoitti:
Sdp lupaa nuorille töitä hallituspaikan vastineeksi

bla bla blaa pla pla


Url-enkoodattuna toimii:
Hesari kirjoitti:
Sdp lupaa nuorille töitä hallituspaikan vastineeksi

bla bla blaa pla pla


Tökkäisiköhän ääkkösiin.

 
 Profiili  
 
 Viestin otsikko: Re: url -tagit ei toimi aina
 Viesti Lähetetty: 27 Touko 2010, 14:29 

Liittynyt: 03 Syys 2002, 16:00
Viestit: 2260
Paikkakunta: tre
Cursarion kirjoitti:
cfe kirjoitti:
Esimerkkinä:

[url=http://www.hs.fi/politiikka/artikkeli/Sdp+lupaa+nuorille+töitä+hallituspaikan+vastineeksi/1135257133146]Hesari[/url] kirjoitti:
Sdp lupaa nuorille töitä hallituspaikan vastineeksi

bla bla blaa pla pla


Url-enkoodattuna toimii:
Hesari kirjoitti:
Sdp lupaa nuorille töitä hallituspaikan vastineeksi

bla bla blaa pla pla


Tökkäisiköhän ääkkösiin.

Tökkää. Kiitoksia. Miten noi urlit saa enkoodattua tuolla tavalla?

 
 Profiili  
 
 Viestin otsikko: Re: url -tagit ei toimi aina
 Viesti Lähetetty: 27 Touko 2010, 14:39 

Liittynyt: 27 Tammi 2008, 16:09
Viestit: 992
Paikkakunta: Joensuu (/Kajaani)
Ennen vanhaan selaimet näyttivät nuo url-koodaukset osoiterivillä, joten ne kopioituivat siitä suoraan. Sittemmin tavaksi on tullut näyttää osoiterivillä ne kansalliset ym. merkit, joita koodaukset tarkoittavat, mutta yleensä selaimet ovat mielestäni osanneet kopioida osoitteen oikein, eli siinä muodossa, että url-koodaukset säilyvät.

Testasin itse juuri Firefox 3.5.9:llä, menin tälle sivulle ja kopioin osoitteen siitä. Osoiterivillä näkyi ääkköset, mutta liittäessä näkyy url-koodausta, eli linkki toimii. Jos katson eri uutista ja kopioin tuon kyseisen ääkköslinkin right-click + Copy link location -tyylillä, homma toimii samoin.

Kuinka kopioit sen linkin? Selaimesta sen tosiaan pitäisi olla kiinni, liekö sinun selaimessasi jotain ylimääräisiä säätöjä osoitteiden kopioimisen kanssa, tai vain joku asetus tyhmästi.

 
 Profiili  
 
 Viestin otsikko: Re: url -tagit ei toimi aina
 Viesti Lähetetty: 27 Touko 2010, 14:45 

Liittynyt: 03 Syys 2002, 16:00
Viestit: 2260
Paikkakunta: tre
Cursarion kirjoitti:
Kuinka kopioit sen linkin? Selaimesta sen tosiaan pitäisi olla kiinni, liekö sinun selaimessasi jotain ylimääräisiä säätöjä osoitteiden kopioimisen kanssa, tai vain joku asetus tyhmästi.

Kopioin osoiteriviltä copy/paste tyylillä. Selaimena on uusin Opera, ja tässä saattaa olla joku päällä.

 
 Profiili  
 
 Viestin otsikko: Re: url -tagit ei toimi aina
 Viesti Lähetetty: 28 Touko 2010, 01:27 
Imperiumi Crew

Liittynyt: 24 Maalis 2004, 13:15
Viestit: 612
Paikkakunta: Espoo
Vinkkinä myös, että Hesarin uutislinkit toimivat myös ilman tuota otsikkoa urlissa. Esimerkiksi sama uutislinkki pelaa näinkin:

http://www.hs.fi/ulkomaat/artikkeli/1135257135634

Pyyhkii vaan itse pastetessaan sen otsikkoräpellyksen öökkösineen pois tuosta välistä.

 
 Profiili  
 
Näytä viestit ajalta:  Järjestä  
 
Aloita uusi ketju Vastaa viestiin  [ 8 viestiä ] 

Etusivu » Imperiumi » Palaute


 
Et voi kirjoittaa uusia viestejä
Et voi vastata viestiketjuihin
Et voi muokata omia viestejäsi
Et voi poistaa omia viestejäsi

Siirry:  
Käännös, Lurttinen, www.phpbbsuomi.com ja www.imperiumi.net